Bravo pump not pumping - are they easy to fix?

Chart Plotters, Fish Finders, GPS, VHF, Lighting & anything powered by 'elec-trickery'
Post Reply
chris moody
Supporting Member
Posts: 1663
Joined: 24 Mar 2015, 12:19
Boat Make: Ribcraft 4.8 Takacat 3.4
Outboard: Honda BF50 Tohatsu 9.8 2s
MMSI Number: 235900806
Location: Braunston & Porchester
Has thanked: 50 times
Been thanked: 192 times
Contact:

Bravo pump not pumping - are they easy to fix?

Post by chris moody » 03 Jul 2018, 09:07

My Bravo pump has decided to make all the right noises, just not pump any air. Has anyone taken one apart, what are the likely bits that fail, and are spare parts readily available?
Chris Moody
Tigga 2: Ribcraft 4.8 Honda BF50
Tiny Tigga: Takacat 3.4 Tohatsu 9.8

Stray
Super Poster
Posts: 657
Joined: 10 Jun 2015, 10:52
Location: Oop North.
Has thanked: 18 times
Been thanked: 71 times

Re: Bravo pump not pumping - are they easy to fix?

Post by Stray » 03 Jul 2018, 09:24

Might be the piston if the motor sounds OK.

http://www.ibsparts.co.uk/bravo-pumps/b ... pumps.html

Never taken one to bits, but it will be the first thing I do if mine fails.

User avatar
Paul
Supporting Member
Posts: 3026
Joined: 30 Dec 2014, 21:46
Boat Make: Mercury Ocean Runner 420
Outboard: Mariner F40ELPT, 3.5 Tohatsu smoker
MMSI Number: 235915479
Location: Bracknell, Berkshire
Has thanked: 460 times
Been thanked: 341 times

Re: Bravo pump not pumping - are they easy to fix?

Post by Paul » 03 Jul 2018, 22:19

Stray wrote:
03 Jul 2018, 09:24
Might be the piston if the motor sounds OK.

http://www.ibsparts.co.uk/bravo-pumps/b ... pumps.html

Never taken one to bits, but it will be the first thing I do if mine fails.
Good shout Stray as I've read about poor electrical connections and the switch over from low pressure/high volume to high pressure/low volume valve switch giving problems, never no air at all :?
I'd have it to bits Chris and check that a internal hose/connection hasn't come adrift first, then work from there :idea:
Please let us know your findings :thumbsup
:cheers

James
Mega Poster, I Really Need To Get Out More !
Posts: 1085
Joined: 01 Aug 2015, 12:25
Boat Make: F-Rib 360
Outboard: 1999 Johnson 2-Stroke 15 HP
MMSI Number: 235914355
Location: Copthorne, West Sussex
Has thanked: 37 times
Been thanked: 59 times
Contact:

Re: Bravo pump not pumping - are they easy to fix?

Post by James » 03 Jul 2018, 23:48

I've stripped mine down before.
However becareful, the wires can come away from the solder easily!
James

2015 F-Rib 360 married to a 1999 fully rebuilt 15hp 2 Stroke Johnson engine and 22 litre fuel tank.
Mods: Launch wheels, Towing Eyes, 2 Bench Seat Cushions, and 1 Bench Seat Bag
Boat name: Cichlid

Post Reply

Return to “Electrical”